[AniMov] Different error messages when trying to use rhr package

Hazel, Julia julia.hazel at jcu.edu.au
Sat Aug 9 13:18:17 CEST 2014


G'day Elodie,

I'm guessing you have multiple problems... maybe you don't have a user guide for rhr (I did not find a user guide)... and you want to run many complex spatial analyses all at once... simply by making selections in a web interface... that is a big ambition!

I had no prior experience with rhr. I installed it now for the first time.

I tried to input your csv file but rhr did not recognise your date-time.  I had to split your timestamp into date and time (two separate fields). 

I subset a few rows for a quick trial. I selected ONLY minimum convex polygon -wishing to start with something simple!

rhr did provide a reasonable report including plot, in an html page, following basic 'reproducible research' practice. 

It seems rhr is still in development. When it reaches a robust working stage, it will be very nice. However at present it gave me a lot of warning messages, impossible to interpret properly. It would be very difficult to determine which messages might relate to your input and which relate to assumptions behind rhr coding - assumptions that might not be met on your or my system.

My suggestion would be to contact the developers of rhr directly, if you continue with this package. And start with a small dataset, doing one analysis at at time.

Alternatively, take a deep breath and use command line R (via R studio if you like) and calculate your home ranges using adehabitat - after first reading the helpful user guide.

Good luck with your work. I look forward to reading (later on) about your foraging penguins :)

Julia



Julia Hazel Ph.D.
Adjunct Research Fellow
School of Earth and Environmental Sciences
James Cook University, Townsville
QLD 4811
Phone: 0407 431 382 (international +61 407 431 382)
Email: Julia.Hazel at jcu.edu.au
________________________________________
From: AniMov [animov-bounces at faunalia.it] on behalf of Elodie Camprasse [elodie.camprasse at gmail.com]
Sent: Saturday, 9 August 2014 15:44
To: animov at faunalia.it
Subject: [AniMov] Different error messages when trying to use rhr package

G’day everyone,
I am working with GPS data recorded from foraging penguins. I recently discovered the rhr package, which seems like an amazing tool but unfortunately I cannot get it to work.
I have a dataframe that contains one column for longitude and one for latitude, as well as an ID column which gives information about the trip number (I want to calculate home range characteristics trip by trip and then make a comparison) and a POSIXct timestamp in the format d/%m/%Y %H:%M:%S as you can see in the attached file.

The rhrGUI() command allowed me to open the GUI in my web browser (Google Chrome) after loading the package rhr. I uploaded the file with “comma”, “data comes with header”, “0”, and “point” as options for the field separator, header, skip lines and decimal separator options. In order to map the fields, I used “id”, “Longitude”, “Latitude” and “timestamp”, and “NA” for he ID, Longitude, Latitude, Date and Time fields respectively. For the date, I used the “ymd_hms” option. I did not apply any restriction. I then selected “lon/lat” (but I also tried meters and got the same output with errors), “4326” (for WGS84), “28354” (which corresponds to the projected coordinate system of the zone I am working with, ie GDA Zone 54), “add random noise” for the unit, input spatial reference system, output reference system and duplicates fields separately. On top of that, I ticked the verbose mode, write log and use Google maps options. I ticked all analytical steps and ran the analysis but I am getting error messages throughout the output and no plot at all get produced.

Here are the error messages I am getting:

-   Site fidelity: Error in switch(ct, ggplot = ggplotGrob(grobs[[ii.table]]), trellis = latticeGrob(grobs[[ii.table]]), : EXPR must be a length 1 vector

-   Time to statistical independence: Error in valid.viewport(x, y, width, height, just, gp, clip, xscale, yscale, : invalid 'yscale' in viewport

-   Minimum Convex Polygon/Kernel Density Estimation: Error in rhrConvertUnit(tt$area, config$config$inUnit, config$config$outUnit): inUnit is not valid. It should be one of: ido,m,km,ft,yd,mi

-   Local Convex Hull: Error: is.character(projargs) is not TRUE

-   Asymptote and Core Area: Error in gzfile(file, "rb"): cannot open the connection and Not enough relocations

I am not sure what these errors mean and how to fix them.

I should probably mention that I installed the package rhr from the zip file found on r-forge a few days ago.

I have also attached the log and params files created after the analysis was ran.

If someone could help me understand what seems to be the problem and point me in the right direction to fix it, it would be much appreciated!
Cheers,

Elodie



Elodie Camprasse
6/187 Auburn Road
Hawthorn, VIC 3122
Australia

Email: elodie.camprasse at gmail.com<mailto:elodie.camprasse at gmail.com>
Website: http://hors-des-sentiers-battus.e-monsite.com/
Mobile: (+61) 049 794 0793<tel:%28%2B61%29%20049%20794%200793>



More information about the AniMov mailing list