[AniMov] I found the problem! :) FW: problem loading Hore Range plugin for QGIS

Giovanni Manghi giovanni.manghi at gmail.com
Tue Jan 25 12:47:43 CET 2011


Hi Addy,

yes, in R 2.12 the location of the executables files has changed, this
makes the HR plugin not working. I'm not a python/R guy, but probably
the library that have to catch up is rpy2(?).

In any case there are still unsloved problems in the plugin (Anne, do
you confirm?): using an older version of R (2.9.2 is what I observed) is
the workaround at the moment.

Cheers

-- Giovanni --


On Tue, 2011-01-25 at 12:29 +0100, Addy de Jongh wrote:
> Dear Giovanni,
> 
> I have found the problem. I used the newest R (-2.12.1), and in this the R.exe and R.dll have been put in a separate I386 folder in the BIN folder. I have now removed the newest version of R and replaced it by R-2.10.0, which has no I386 folder in its BIN.
> 
> Obviously the code in the Home Range Plugin is looking for the R.dll in the BIN folder, but not in the I386 folder inside the BIN in the newest R version.
> 
> So for new users like me, there should be a notification/warning on http://www.qgis.org/wiki/HomeRange_plugin#State_of_the_art NOT to use a newer version of R than 2.10.0 in windows (I am using windows 7 ultimate).
> 
> Now I am looking forward to really use the plugin for Home Range Analysis of our otter data. Thanks for making this open source software available!
> 
> Best wishes,
> Addy de Jongh,
> director Dutch Otterstation Foundation,
> Dutch Representative IUCN/SSC Otter Specialist Group
> 
> -----Oorspronkelijk bericht-----
> Van: Addy de Jongh [mailto:addydej at xs4all.nl] 
> Verzonden: 24 January 2011 22:34
> Aan: 'giovanni.manghi at gmail.com'
> Onderwerp: problem loading Hore Range plugin for QGIS
> 
> Dear Giovanni,
> 
> How are you? Remember me? Friend of Lorenzo. I noticed you came a long way with the open source GIS developments. Nice.
> 
> For our VHF and GPS tracking work the HomeRange plugin for QGIS looks very promising to me (http://www.qgis.org/wiki/HomeRange_plugin#State_of_the_art). I have tried to install it following correctly the installation requirements on my windows 7 PC.
> 
> It is however a pity that I get all the time the error messages shown in the attachments. I have set R_HOME manually to the ~\BIN\I386 folder, but also to the root of these C:\Progra~1\R\R-2.12.1. Neither of these settings works.
> 
> Therefore I like to ask you if you have any idea, what might be wrong here.
> 
> Your help is much appreciated.
> 
> Best wishes,
> Addy de Jongh,
> Dutch Otterstation Foundation,
> Netherlands
> 
>  




More information about the AniMov mailing list