[AniMov] HR QGIS plugin error

Giovanni Manghi giovanni.manghi at gmail.com
Mon Jun 28 21:23:10 CEST 2010


Hi Anne,



> this is my [r]gdal installation on Debian testing, and it works. The
> shapefile is correct, only the "ha_percent" column name is trimmed - as
> Non-fatal Error 6 mentioned in previous mail warned.
> Some questions:
> - Which version of [r]gdal are you using?



Under Ubuntu 10.04 I see

> require(rgdal)
Loading required package: rgdal
Loading required package: sp
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.7.2, released 2010/04/23
Path to GDAL shared files: /usr/share/gdal17
Loaded PROJ.4 runtime: Rel. 4.7.1, 23 September 2009
Path to PROJ.4 shared files: (autodetected)


> packageDescription("rgdal")
Package: rgdal
Title: Bindings for the Geospatial Data Abstraction Library
Version: 0.6-27
Date: 2010-05-11
Depends: R (>= 2.10.0), methods, sp (>= 0.9-60)



Under Windows Seven I see

> require(rgdal)
Loading required package: rgdal
Loading required package: sp
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.7.1, released 2010/02/08
Path to GDAL shared files: C:\Users\gio
\Documents/R/win-library/2.10/rgdal/gdal
Loaded PROJ.4 runtime: Rel. 4.7.1, 23 September 2009
Path to PROJ.4 shared files: C:\Users\gio
\Documents/R/win-library/2.10/rgdal/proj


> packageDescription("rgdal")
Package: rgdal
Title: Bindings for the Geospatial Data Abstraction Library
Version: 0.6-26
Date: 2010-04-10
Depends: R (>= 2.10.0), methods, sp (>= 0.9-60)


I installed r 2.10.1 on both systems.


> - Is anything much different from the working configurations listed in
> the plugin's wikipage?


not much, on windows I use just osgeo4w packages, on Ubuntu I'm using
the ubuntugis repository and qgis trunk installed from source.


> - Last, is manageR working fine?


yes, on both systems.



> BTW the error has been mentioned by Agustin Lobo on R-sig-geo [0]
> 
> This is my working configuration:



yes, the difference I see is gdal 1.7.x instead of 1.6.x


could be?


cheers!


-- Giovanni --



More information about the AniMov mailing list