[AniMov] HR QGIS plugin error

Giovanni Manghi giovanni.manghi at gmail.com
Thu Jul 1 12:16:25 CEST 2010


> > yes, the difference I see is gdal 1.7.x instead of 1.6.x
> >
> > could be?
> 
> Could be..
> 
> Can you test this code snippet in R?
> 
> #################################
> require(rgdal)
> cities <- readOGR(system.file("vectors", package = "rgdal")[1], "cities")
> # cities can be any Spatial*DataFrame.
> writeOGR(cities, "/tmp", "cities_full", driver="ESRI Shapefile")
> writeOGR(cities[cities$NAME == "Veracruz",], "/tmp", "cities_one",
> driver="ESRI Shapefile")
> #################################
> 
> if it works with these example data I will dig out another snippet
> closer to plugin's code.


This is the result

Loading required package: rgdal
Loading required package: sp
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.7.2, released 2010/04/23
Path to GDAL shared files: /usr/share/gdal17
Loaded PROJ.4 runtime: Rel. 4.7.1, 23 September 2009
Path to PROJ.4 shared files: (autodetected)
OGR data source with driver: ESRI Shapefile 
Source: "/home/gio/R/i486-pc-linux-gnu-library/2.10/rgdal/vectors",
layer: "cities"
with 606 features and 4 fields
Feature type: wkbPoint with 2 dimensions



cheers!

-- Giovanni --



More information about the AniMov mailing list