[AniMov] Help

Sebastian Cruz cruz.seb at gmail.com
Thu Dec 10 02:16:33 CET 2009


Hello

I have installed the new QGIS MIMAS on my Apple, OS 10.6. I have installed the Homerange plugin, with depedencies (I think). But when I try to run the plug in I get the following message:
An error has occured while executing Python code:

Traceback (most recent call last):
  File "/Users/sebastiancruz/.qgis//python/plugins/HomeRange_plugin/HRplugin_dialog.py", line 76, in 
    QObject.connect(self.buttonBox, SIGNAL("accepted()"), lambda mth=mth: self.run(mth))
  File "/Users/sebastiancruz/.qgis//python/plugins/HomeRange_plugin/HRplugin_dialog.py", line 178, in run
    if not robjects.r.require(i)[0]:
NameError: global name 'robjects' is not defined

Python version:
2.6.1 (r261:67515, Jul  7 2009, 23:51:51) 
[GCC 4.2.1 (Apple Inc. build 5646)]

Python path:['/Applications/Qgis.app/Contents/MacOS/../Resources/python', '/Users/sebastiancruz/.qgis//python/plugins', '/Applications/Qgis.app/Contents/MacOS/../Resources/python/plugins', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python26.zip', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-old', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload', '/Library/Python/2.6/site-packages', '/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/PyObjC', '/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode', '/Applications/Qgis.app/Contents/Resources/python/plugins/fTools/tools']

Do I need to update my Python? Any suggestions are accepted.

Thank you for your help

Sebastian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.faunalia.it/pipermail/animov/attachments/20091209/425d9136/attachment.htm>


More information about the AniMov mailing list